Syncing problem still happening.

This topic contains 6 replies, has 2 voices, and was last updated by  daffy 2 months, 1 week ago.

  • Author
    Posts
  • March 14, 2019 at 10:30 AM #33997

    daffy
    Participant

    Hi,
    I was experiencing problems with syncing my database, but I thought we had found the answer, only it’s happening again.

    My main database is updated on my Mac. I sync to my MacBook and my iPhone and iPad.

    The Mac seems to be stuck on ‘sync receiving (2799)’.

    Previously I thought it was because of the size of my database. I had added my pdfs files rather than an alias link. They have all been changed to alias’ now and all my images have been resized. The whole database is now 857.3 MB in size. Is this still too large?

    There are 599 records in my form and my iPhone has only managed to sync 358 of them. It hasn’t synced any data since two days ago.

    Any ideas what I can try next?

    March 15, 2019 at 1:17 AM #34000

    Brendan
    Keymaster

    Did you compact your database before you started sync from scratch again? If not, it could help.

    March 15, 2019 at 12:17 PM #34002

    daffy
    Participant

    Yes, I did. That how I was able to reduce it to 857.3 MB from 4GB.

    I deleted the data from all my devices and iCloud and then set it syncing again from my Mac and it got stuck again. I left it running last night around 10pm and it’s now 7pm and it’s stuck on ‘sync receiving (2596)’.

    Why is it receiving though? If there is no data own my other devices and I’ve deleted the data on iCloud, why is it trying to receive data? Shouldn’t it just be uploading data?

    March 15, 2019 at 7:35 PM #34007

    Brendan
    Keymaster

    Because when you upload to iCloud, the data is uploaded. But then when you open the document again, Tap Forms checks to see if any data is in iCloud. The same data you just uploaded gets downloaded again along with some metadata that iCloud sync needs in order to determine if the data synced is new or updated. So there’s 2 sync cycles initially. One upload, then download. It’s definitely inefficient, but I couldn’t find a way around it. It doesn’t do that with the other sync services because they work differently than iCloud. That’s one reason why the other sync services are more efficient and faster than iCloud. But iCloud is a bit simpler to setup because you don’t need an account as you already have one.

    March 15, 2019 at 11:45 PM #34010

    daffy
    Participant

    Hi Brendan, that makes sense, thank you for explaining.
    I don’t mind that it takes a little longer because of this double syncing, but I still can’t get it to do a full sync.

    I left it running last night and it’s still on 2596, so I know I’m going to have to stop it and try again, but the problem is, I don’t know what to try next to make it work.

    Any ideas?

    March 17, 2019 at 1:55 AM #34014

    daffy
    Participant

    UPDATE:
    I managed to get the iMac version to upload to iCloud without it getting stuck.
    I still couldn’t get the iPad, iPhone or MacBook apps to retrieve all of the information though. Each device would constantly start syncing and get stuck. I left them several hours and gone back to find them still stuck ‘sync receiving’.

    To break the cycle I restarted the app, the same thing would happen each time. The devices were receiving over 2000 pieces of info, but the number of records in the database never increased. They just stayed the same.

    Eventually I tried again with my iPad and I thought it was stuck, but then the number of records started increasing until they were all there, 599 of them.

    Next I got the MacBook syncing again, but this too is getting stuck. I keep restarting the app and I’m hoping it will eventually catch up and then I will try with my iPhone.

    Are there any reasons why I might be experiencing this problem and what can I do about it to try and future proof my database? Although my iPad is now showing a full set of records, I haven’t yet tried to make any changes and see if the updates sync straight away or if it continues to get stuck. I am trying too fix one problem at a time rather than trying to do it all in one go.

    March 17, 2019 at 3:30 AM #34015

    daffy
    Participant

    UPADTE 2:

    I have now got all 599 records on all of my devices and Macs. There are still some images missing on the iPhone though and when I try and get it to sync it doesn’t, it’s as though it thinks it has already synced to the latest version and so won’t pick up and more info. I am going to try making small changes on my iMac and see if it triggers the sync on the iPhone.

    Getting there, but still quite frustrating.

You must be logged in to reply to this topic.