Layouts in a form not synchronising

This topic contains 3 replies, has 2 voices, and was last updated by  Brendan 2 months, 2 weeks ago.

  • Author
    Posts
  • February 6, 2019 at 5:41 AM #33672

    Victor Warner
    Participant

    Using TapForms 5.3.5, macOS 10.14.3.

    I have a database consisting of several forms. One form has 3 layouts. I synchronise between 2 Macs using iCloud.

    The issue: For the form with 3 layouts two layouts are not synchronised from the one Mac to the second Mac (the default layout is only shown). The records I create or the modifications to records always synchronise.

    I deleted the database from the second Mac (to trash) and copied the database from the first Mac using AirDrop, but this made no difference.

    Is there anything that can be done about this?

    February 6, 2019 at 7:21 PM #33676

    Brendan
    Keymaster

    If you used AirDrop to send a copy of your document to your other Mac, then it should definitely be showing the exact same thing as on your first Mac. Did you try quitting and re-launching Tap Forms?

    February 7, 2019 at 1:51 AM #33681

    Victor Warner
    Participant

    Brendan,

    I have tried quitting and relaunching Tap Forms. And activities have included quitting and relaunching Tap Forms on both machines and rebooting both machines.

    This is a persistent issue.

    I also have a third Mac. There is the same issue (that is the data synchronises but not the additional layouts for one form).

    Is the way around this to export from the first Mac as a Tap Forms Archive and then on the other Macs, to delete the forms on those Macs and import the exported Taps Form Archive from the first Mac?>

    February 7, 2019 at 12:07 PM #33693

    Brendan
    Keymaster

    You could export the archive. But I really see no reason why the custom layouts wouldn’t show especially if you used the Send Document function to send an exact copy of the .tapforms document file over to your other Macs. That just makes no sense to me. Either there’s something I’m missing in my understanding of the situation or maybe you’ve hidden the record details view on those other Macs?

    When you use the Send Document function to send the document with AirDrop, it ends up in the Downloads folder. After that you have to drag it into the main Database Documents list window. Is it possible you’re opening an older version of the file that’s in the Database Documents window but not the one that landed in the Downloads folder?

You must be logged in to reply to this topic.