Back up and passwords

Viewing 6 reply threads
  • Author
    Posts
  • April 10, 2021 at 5:30 AM #44110

    When I quit Tapforms it automatically backs up the open files, which is fine. But one of the files which is password protected then opens automtically when I next re-load Tapforms, without asking for the password. The only way to require the password is to close the file before quitting Tapforms, but then it does not back up.

    I could, of course, back up manually, but that seems to be a different location….

    Am I missing something?

    April 10, 2021 at 9:05 PM #44121

    Brendan
    Keymaster

    Hi Hugh,

    Oh that’s odd. It should be asking you for the password even if it’s opening up automatically on relaunch.

    In fact, I just tested this scenario with multiple documents opening up upon launch. One encrypted, the other not.

    Perhaps it’s opening a version of your document that’s not encrypted? Check to make sure you don’t have multiple documents with the same Document ID floating around somewhere. You can also command-click on a document title window to see where the document is living. Maybe it’s not in the usual place.

    Thanks,

    Brendan

    June 4, 2021 at 1:11 AM #44506

    Brendan

    There are two identical copies of the file, one in Library/Containers/Tap Forms Mac 5/Data/Documents, the other in a sub-folder of iCloud/Documents.
    If I close Tapforms, it automatically backs up the file (into the correct Backup folder in Library – this does not seem a problem at all.)
    When I next load Tapforms it shows both versions in “Recent”. The one in Library opens without the password, the one on iCloud needs the password. (When I make changes, they appear identically in both files.)
    If I open the file directly from either Documents or Library in Finder, I get the same result.
    Later:
    I have now tried moving the file in Library to Bin then reopened Tapforms; the file immediately appeared in Library even before I tried to open it. This Library version is (now) empty, when I open the one from iCloud it requires the password. But both versions appear in Recent and again, password required for the iCloud one, not for the (new, empty) Library one.
    I wish to keep it in iCloud for the off-site back up, how can I prevent it appearing in Library?
    There is a setting in Preferences for Scripts which is set to Documents. I don’t use scripts though there is one that I was playing with in the file – could this be muddling things?
    Hugh

    June 4, 2021 at 12:04 PM #44510

    Brendan
    Keymaster

    Hi Hugh,

    You should move the one that’s in iCloud back into the Library folder. You should not open a Tap Forms document that’s sitting on a cloud storage service such as Dropbox or iCloud Drive.

    If you want backups to be in iCloud Drive for safe keeping, that’s fine. Set the Backup Folder on the Preferences window to a Tap Forms Backups folder you can make on iCloud Drive.

    But if you open and work on the document that’s sitting in iCloud Drive, you risk the embedded SQLite file becoming corrupted due to iCloud syncing things behind Tap Forms’ back.

    The reason you are seeing the file appear back in Library, but empty this time is that you probably also have iCloud Sync enabled for that document and Tap Forms is downloading the placeholder document for you from Apple’s CloudKit servers.

    Scripts has nothing to do with this issue.

    Thanks,

    Brendan

    June 6, 2021 at 4:43 AM #44530

    THanks, Brendan, I’ve sorted the locations as you suggest. In the course of doing this I have re-named the files (I was getting very confused with so many versions.) I am now finding that the files do not update on the iPad even though the Sync Setting Database code is identical. I have switched of iCloud Sync in both files and deleted the iCloud versions, but the sync does not happen. Have I really confused things by changing the name? The Sync Setting Database codes did not change when I changed the file name.

    Hugh

    June 11, 2021 at 8:45 AM #44597

    I now have the databases syncing macbook to ipad after I disabled the iCloud sync, deleted the file on iCloud, then set it all back up. However, the passworded file opens on the ipad without a password. The macbook version has always been passworded and in Preferences/Security, the button implies that the file is encrypted (it says, “Decrypt Document…”) But on the iPad, in Tools/Security Settings the button reads “Encrypt Database.”

    June 11, 2021 at 2:14 PM #44600

    Brendan
    Keymaster

    Hi Hugh,

    Encryption is done on a per document basis. Had you used the Send Document function to send a copy of the document from your Mac to your iPad, then your document would have been encrypted. But with iCloud sync, the data is not encrypted separately using the same encryption key as you used for your document locally. So when it syncs across to your iPad, the database over there won’t be encrypted. You just have to encrypt it again. Or send the already encrypted document from the Mac to the iPad using the Send Document function. But you’d want to remove the document from your iPad first before you do that.

    iOS 15 and macOS Monterey have a new feature where you can encrypt data separately that’s stored in iCloud. I’ll see about implementing that in a future upgrade.

    Thanks,

    Brendan

    September 19, 2021 at 2:39 PM #45325

    Paul Wirth
    Participant

    iOS 15 and macOS Monterey have a new feature where you can encrypt data separately that’s stored in iCloud. I’ll see about implementing that in a future upgrade.

    I came here to ask about encryption on iCloud. Very happy to hear that this is a possibility on iOS 15 and macOS Monterey. Please keep us posted!

    Paul

Viewing 6 reply threads

You must be logged in to reply to this topic.