iCloud sync not working (yes, I know..)


Viewing 28 reply threads
  • Author
  • September 7, 2013 at 2:34 PM #6617



    I have the Mac version, and the iPhone version.

    The iCloud sync on the Mac “seems” to work: I can activate it, and the DB is indeed copied in /Mobile Documents…

    On the iPhone? No success.
    Whatever I do, the sync remains blocked at “Upload 0.0%” (I have waited up to 30 minutes, and this was with the default DB and its 2 records!).
    I have tried several times over 3 weeks and from 2 countries, so iCloud downtime/exotic ISP port filtering is not an option.

    I have already read and tried solutions from https://www.tapforms.com/forums/topic/icloud-sync-iphone-with-ipad-problem/
    My attempts include dozens of combinations of the below actions, in different orders:
    – Deactivating iCloud in Tapforms
    – Reseting iCloud in Tapforms
    – Deactivating iCloud docs sync in the phone
    – Restarting phone
    – Reactivating iCloud docs sync in the phone
    – Removing the iCloud account from the phone altogether
    – Re-entering my iCloud account in the phone.
    – Deactivating iCloud sync on the Mac + clearing the /mobile documents folder
    – Combinations of Wifi/Cellular on/off.

    Any help is welcome, I have browsed 100 pages to find a solution, but I may have missed something of course!

    Now Brendan, I don’t want to sound as an angry user. Really, I am not!
    But I won’t loose any more time on something that “should just work” (e.g. full backups/restores of the phone). Plus, it is very likely Apple’s fault…

    Here is my conclusion for the moment, as a user:
    – I still trust Tapform is “my” alternative for Bento, but I can’t use it yet.
    – iCloud sync – which I had never needed – turns out to be exactly as read too often: unreliable, non-transparent for developers and users alike, capricious.
    So, this is just my opinion, but I trust many others will come: PLEASE think about supporting tried, tested and cross-platform sync methods: wifi, dropbox, webdav for personal cloud solutions…or messaging pigeons for all I care ;-)


    September 7, 2013 at 9:59 PM #6620


    Hi Pierre,

    One of my customers today told me that they had troubles with iCloud sync in Tap Forms and also in Apple’s iWork applications. They contacted Apple Support and Apple said that the problem they were having was because they purchased the iWork apps with one Apple ID, but are trying to sync it with a different account that they use for iCloud. Now, I’m not sure if that’s really the case for everyone, but that seemed to be the trouble for him.

    Tap Forms and iWork both use the Documents & Data iCloud sync service to do the syncing. So if you see the same kinds of troubles with iWork, then maybe you’re experiencing a similar issue.

    When you look in the SyncDocuments directory on your Mac for the Tap Forms iCloud container, do you see just a single TFSyncDevice file? If so, then iCloud isn’t sending the files from your iOS device(s) to your Mac. That’s a big indicator that something isn’t working right with iCloud Sync.

    The progress bars will mostly just sit at 0%. They will move only after some time when files are either being downloaded to Tap Forms from iCloud or you’re uploading files to iCloud from Tap Forms. That will only happen on your iOS device when you tap on the Sync button on your iOS device. But it won’t happen right away. It will happen sometime AFTER the messages in the status bar stop displaying. During the display of those messages, Tap Forms is simply gathering all the changes you’ve made since the last time you tapped the Sync button and generating a database file that contains just those changes.

    After that happens, iCloud should kick in and upload the change file Tap Forms generated to Apple’s iCloud servers. That’s when you may or may not see the progress bar increasing. It normally will increase when you’re syncing for the first time (or after doing the Reset iCloud Sync procedure and syncing again for the first time). But it really all depends on how much data you’re syncing too. If your database is quite small, then most likely the progress bars won’t increase. Or if you’re just syncing a small change.

    It would be interesting to see what’s in the mobile documents folder for Tap Forms on your iOS device. The only way I know of to look into that is to use the iExplorer app from http://www.macroplant.com/iexplorer. It will let you look at all the iCloud files generated by all the apps that you have on your iOS device that use iCloud.

    If any of this helps, let me know. Or even if it doesn’t :-)



    September 8, 2013 at 4:28 PM #6623


    iCloud sync works perfect for me between the iPad and the iPhone. I too sat waiting 30 min for the sync to happen until I realized I had to hit the chasing arrows symbol to manually start it.

    It’s been working well ever since. Don’t know if this will help you or not.

    September 8, 2013 at 5:33 PM #6625


    Thanks HappyTapper. I had tried that already. This “auto-pull, manual push sync” thingy really confuses the hell out of me…I guess I am missing the logic ;-) In any case, I had already tried: 2 or 3 steps appear at the top of the phone, for 2-3 seconds, but nothing else changes.

    Brendan, thanks for the detailed response!
    – About conflicting accounts:
    I bought the Mac and the iPhone Tapforms with the same “Apple ID” account. This same account/email/Apple ID is also my unique iCloud account.
    I do have another “Apple ID” (with a credit card from another country). However, I only use this account in iTunes on the Mac to purchase music occasionally (log on, then back to my “main” Apple ID). I don’t think my phone is even aware that I have this account, and in any case it is NOT an iCloud account, just an Apple ID with CC info for iTunes.
    > I am talking about my 2nd account just so you get the full picture. Since it’s not an iCloud account, I guess this excludes this explanation, doesn’t it?

    – iWork / other apps
    Well, I don’t have these, so I can’t say.

    – SyncDocuments folder
    I see 2 files:
    1) “TFSyncDoc…”. which “last modified” timestamp seems to match the “first time” I reactivated iCloud sync on the Mac for this new test (about an hour ago)
    2) “TFSyncDevice…” which timestamp updates every time I force the sync in Tap Forms Mac.
    >Activating sync (and pushing the arrow button) on the phone doesn’t change the content of this folder on my Mac (even after a few minutes).
    >Also, I just realized this: it seems both devices don’t “see” each other (the Mac sync windows shows only the Mac, the iPhone sync screen only the iPhone).

    I don’t think this helps you further in troubleshooting.
    I don’t have time to explore the content of my phone folder with the tool you mentioned for now. But I know I’ll probably be tempted to do so soon…


    September 8, 2013 at 7:55 PM #6627


    Hi Pierre,

    So this is the main problem you’re having then. iCloud isn’t syncing the files I generate on the iPhone over to your Mac. Both devices need to be able to see each other in the list of Registered Devices in Tap Forms. That list is actually just displaying the contents of each TFSyncDevice file. When you enable iCloud Sync in Tap Forms on any device, Tap Forms creates one of these TFSyncDevice files in the SyncDocuments folder in Tap Forms’ iCloud container as you’ve seen. Even your iPhone has this folder when you enable iCloud sync in Tap Forms. Your iPhone also will create one of these files. It will have a different random string after it though in order to keep the files unique.

    That’s pretty much the end of what Tap Forms does after you enable iCloud sync. Getting those files around to all of your devices is the responsibility of Apple’s iCloud processes running on your device. These processes run independently of Tap Forms. They monitor the contents of the folders that I write into and then they automatically sync those files to your other devices.

    So when you enable iCloud sync in Tap Forms, a TFSyncDevice file is generated and then sent to your other devices. For each device that you’ve enabled iCloud sync on, you should see one TFSyncDevice file. If you only see one, then that’s the one that has been generated on that machine and the other devices are either not uploading the files to Apple’s iCloud servers, or your Mac isn’t downloading the files from iCloud. This part of the process is beyond what Tap Forms does with these files. I write the files, then iCloud takes over from there out of my control.

    As for the manual push, automatic pull, it’s just you initiating the sync process from the device you’ve made changes on. You’ll see messages appear at the top of the screen when you tap the sync button.

    Instead of thinking about it as syncing, think about it as you making a change, then sending those changes over to your other devices. When your other devices receive the changes sometime later, they will apply them to their local copies of the TapForms_db.sqlite database file automatically. That’s all that’s going on.

    As for what to do to get iCloud sync to work for you, well that’s a good question because different things seem to work for different people. Have you tried signing out of iCloud on all your devices, then signing back in again? Have you tried rebooting all your devices?

    I hope this helps clear some things up.



    September 10, 2013 at 5:34 PM #6629



    Is there anyway to verify that iCloud is working for you in general? Even between Mac to Mac? Say push a text in TextEdit to the cloud and see if it shows up on another Mac?

    Or, now that I think of it, log into http://www.icloud.com with your Apple ID, create an iWork document of some sort, and see if it shows up on the Mac in your Mobile Documents folder. That would at least show that the Mac-iCloud part is working.

    FYI I have had good luck with iCloud in a host of applications. Good results between multiple Macs, my iPhone and iPad. I find your problem as puzzling as I am sure you find it frustrating.

    September 10, 2013 at 6:26 PM #6630


    I also had problems getting iCloud sync to work when it was introduced but it has been behaving itself for the last 6 months between Mac, iPad & iPhone. The most frustrating thing were unexpected delays with iCoud, sometimes for a few days.

    As an alternative to get you by until you sort it out, you could rely on making a manual backup to Dropbox with one device and then download the backup onto the other device (s). At least the logic is more understandable and easier to monitor.

    September 11, 2013 at 9:07 AM #6634


    @All thank you for your cooperation ;-)

    @ Brendan
    I have tried completely login out of iCloud on both the iPhone and the Mac. No change.
    On the Mac, i made sure to clean out the leftovers of MobileMe (I looked it up).


    Very good idea!
    1) Mac <> iCloud: Fail
    I created an iWork text document on iCloud.com : it does NOT appear on the Mac (the Mobile Documents folder remains empty – or just with local Tap Forms stuff if I turn iCloud on for TF).
    2) iDevices <> iCloud: OK
    I recalled I had another iCloud app (DocsToGo). Created a doc on the phone. Still didn’t appear on the Mac (confirms point above). The same document however appeared on my iPad, and then synced back with changes to the phone.

    So now I know: my mac doesn’t want to sync documents with iCloud (though it syncs contacts, calendards, reminders…).
    I have no idea what is happening. I am on Lion 10.7.5.
    Somehow I still think my past as a Mobile Me user has screwed up something. Anyhow, I’ll keep looking online when I have a chance.


    September 11, 2013 at 11:54 AM #6635



    I have both Lion and ML machines. iCloud on ML is decidedly more robust that it is on Lion, but it does usually work on Lion. (Though I have not run Tap Forms on Lion. I’ll try and remember to test this.) I found that on Lion, certain apps were better able to trigger a sync than other apps. So I would sometimes run them to get the other app’s files to sync. Expedient , if not elegant. The only reason I still have ANY machines still on Lion is because ML does not run on them. :-( I should add that I am a Mac admin for my family and work. That’s the reason for the multplicity of machines I have accounts on.

    As to the other items, calendar, book marks, etc. Those always worked well on Lion. Macs had that ability long before Lion came out (Snow Leopard?, Leopoard?) The mechanism behind those is not the same as iCloud. If syncing works, then this is good news in the fact that at least Apple servers and your Mac can talk to one another. I presume that your iDevices are syncing this calendar/bookmark data too? That shows you have the right Apple ID for all of them.

    I doubt it’s a past Mobile me account issue. I am an old .mac subscriber. I subscribed becuase of all the machines I managed. Manually syncing those machines with key data was such a chore I opted for the paid subscription to .mac. The cost was made up in savings of headache pills. :-) So I now have .mac, .me, and .icloud addresses. As long as the AppleID is consistent across Apple products, you should be good.

    I recommend openning up the iCloud preference and turning off the Document syncing, turning it back on, and then checking the Mobile Documents folder again. Also, after that, try adding something to iCLoud via your iPad. I suspect that your Mac is just not properly linked to iCloud. These action might help.

    Lastly, if you can, consdier an upgrade to ML. iCloud in Lion is rather half baked. iCloud supported apps in ML give you the option to store/ retrieve items in the cloud in the usual file dialogs. Quite nice. In Lion, you often have to do back flips to do this. Better than manual file transfers, but only barely in some cases.

    Best of luck!

    September 11, 2013 at 12:04 PM #6636


    Thanks ArsAstronautica.
    I meant .mac for me as well (I’m starting to loose track…). Anyhow, you’re doing fine, so that’s not it.

    I tried stoping doc sync, deactivating icloud altogether… no change…
    I also tried the tips on top of this page: https://discussions.apple.com/message/19374567#19374567
    No change…

    I’m waiting for Mavericks (which might have a direct path from Lion if I believe one of 1000 rumors). I’ve done Leopard>SL>Lion and I got bored of small upgrades; but that’s a debate that’s not relevant here ;-)
    I’m going to keep looking. There must be one little stupid thing that has changed on my computer and that blocks documents sync…

    September 11, 2013 at 12:09 PM #6638


    Good point. Mavericks is due out later this month. Might as well wait until then.

    September 11, 2013 at 8:01 PM #6640


    iCloud is actually a lot of different services that Apple bundles under a single name. But things like Calendar, Mail, Photo Stream, Documents & Data, etc. all communicate with different servers and different back-end applications. So when one service is working, that doesn’t mean they’re all working. Tap Forms only uses the Documents & Data service.

    It does work on Lion. In fact I’ve been testing out my iOS 7 version syncing against the Mac App Store build of Tap Forms Mac on Lion. I wanted to make sure that you could sync bi-directionally between the iOS 7 version of Tap Forms and the current App Store Mac version. Had to make a few changes to get it to work, but it seems to be working well now. This is good because I am not finished the Mac update, but I want to release the iOS 7 update this week so it’s in your hands by the time iOS 7 is out.



    September 12, 2013 at 2:19 AM #6643


    Hi Brendan,

    Thanks for explaining iCloud behind the curtain. Just for the record: as a reasonably informed user, who’s been around since .Mac, I actually knew that! I did gladly indicate some basic things (like “contacts sync correctly”), because your logical 1st assumption would be that the user has messed up with iCloud account settings… and it was ;-) Also, being a modest geek doesn’t prevent from making very basic mistakes, I was hoping I had forgotten to press a button that was right before my eyes…

    I tried some new things based on internet searches, in that order:
    – Deactivated Tap Form iCloud sync.
    – Turned off iCloud doc sync
    – Deleted the “ubiquity” folder in my library & the Mobile Documents folder
    – Turned on iCloud doc sync (Mobile Documents folder immediately came back)
    – When opening Tap Forms (even with iCloud sync off), the Tap Form subfolder in Mobile Documents reappears

    Based on other pages:
    – I checked the ubd (ubiquity) deamon plist file: it is set to not boot at startup and not to be kept alive, which seems to be a normal setting since Mac OS 10.7.3
    – The deamon is indeed not running
    – When opening Tap Forms and activating iCloud sync, the ubd deamon becomes active, as it should be.
    – I tried temporarily modifying the plist so the deamon would be always running (startup+keepalive, which admittedly is not the way it should be again since 10.7.3). It worked, the deamon was always on, but as expected: the problem doesn’t seem the deamon running or not, it just doesn’t sync with the cloud even when it’s there….

    I am still puzzled….

    September 12, 2013 at 6:17 AM #6644


    Hello Pierre,

    One more thing to try is to setup a new iCloud account and see if that works. It could just be something with your current iCloud account on Apple’s servers which are preventing sync from working.

    Have you tried just sticking a file inside any one of those Mobile Documents folders and seeing if it shows up on any of your other devices?



    September 12, 2013 at 8:30 AM #6646


    Hi Brendan,
    I’ve been using my .mac email address for as long as I can remember. Changing iCloud account is not an option.
    > Even if I did create one just as a test, and if it did suddenly work: could I learn something about the error on my actual account?

    I’ve very briefly looked at the software you mentioned to see the iPhone content, I haven’t found the Mobile Documents folder anywhere
    > They say it requires a jailbroken device to actually see the device root, did I miss something?
    I see what you mean by “sticking a file” on the mac. I can do that,
    > but with which iPhone app would I be able to see on the phone if the file has been transferred?
    I am fairly computer literate, I know the terminal, I know my way around Unix/Linux…but when it comes to this (swearword) non-transparent iCloud document sync, I am lost.

    As described above, I have created a .doc file on the iPhone with “DocsToGo”, it syncs perfectly with my iPad. But nothing (not even the app’s folder) appears on my Mac…

    I know you provide great support, so I am sure you will answer those questions sooner or later.
    After that, I’ll just start looking for another solution that support Dropbox syncs. Tap Form is really great, but I have lost the faith I never had in iCloud sync ;-)


    September 12, 2013 at 9:43 AM #6647


    This thread has been really informative. Thanks. This seems to be a case of a particular Mac setup not playing nice with iCloud, with Tap Forms is doing what it’s supposed to do. After understanding that changes must be “pushed” up to the cloud as opposed to that part happening automatically (I think a brilliant design choice) I’ve had a flawless experience on a Mac (mid 2011 MBA, upgraded L to ML), iPad, and iPhone so far. But (especially since Tap Forms makes that so easy) I do make backups just in case! Dropbox sync in other apps works well for me in general, but that’s not to say I haven’t experienced mysterious glitches there. Same experience with Simperium. Syncing is a beast. The Tap Forms implementation via iCloud is great. Kudos!

    September 12, 2013 at 12:58 PM #6650


    Thanks Sumnerg!

    I do want to make it fully automatic at some point, but it’ll just take some hard thinking on my part. I need to coordinate things plus make sure I don’t over do it with too many syncs. Imagine importing 1000 records and Tap Forms sending off 1000 sync requests. That would be silly of course, but I have to think about when to sync and when not to sync and when to hold off on syncing until a later point in time, without too much interference with the user.



    September 12, 2013 at 1:07 PM #6652


    Hi Pierre,

    iExplorer can view the contents of the Mobile Documents folder without jailbreaking. It just doesn’t show you “Mobile Documents”. Instead, under the iCloud item in the sidebar, it lists all of the apps which use iCloud. That’s the equivalent of looking into the Mobile Documents folder. You would see Tap Forms listed there as one of the apps and within it you would see the Documents and SyncDocuments folders.

    So iCloud sync works for you from iOS to iOS device? Well that’s a good thing then. Definitely something up with your Mac. I too am using an old old mac.com address for my iCloud account. It works fine on my Mavericks machine and my old Lion machine.



    September 17, 2013 at 1:37 PM #6661


    Hi Brendan,

    At this point, we all know I have an iCloud problem on my Mac, not a Tap Forms issue.
    I’m annoyed but I can’t let it go.
    So, just in case, here is a summary of the situation (point 1) and new tests I did (points 2 & 3):

    1) iCloud sync works between my iOS devices
    (confirmed in previous posts)

    2) iCloud sync works from iOS to another Mac
    I used another old MacBook Air I had (under Lion).
    Activated iCloud doc syncs, installed Tap Forms. Activated iCloud sync.
    The sync works! The iPhone Tap Form app lists and syncs with the Mac. Also, my Mobile Document folder on the Mac gets filled with many folders I didn’t know existed in my icloud (for example, I can finally see a folder corresponding to the iCloud backups of an iPhone fitness app I have).
    > my iCloud account is not “screwed up” (I read online some people had to bother Apple to reset it, but mine is working fine).

    3) A half-clean install on my main MacBook Pro doesn’t help :-(

    I wanted to switch to an SSD on my main MacBook Pro anyway. So I had to do a “1/2 fresh” installation:
    – Deactivated iCloud completely (log off + delete local data), restart just in case
    – Time Machine backup
    – Old drive away, new empty SSD in
    – Fresh install of Mac OS Lion + all updates
    – Data migration assistant > import my TM backup
    – Reactivated iCloud (incl. doc sync).

    Still not working! That means one thing to me: by restoring with a TM backup, I imported the problem. There is one small setting, somewhere, that disturbs iCloud doc sync or the ubd deamon (although the latter still launches correctly with Tap Forms).

    I’m going to try and understand this ubd deamon a bit better, maybe try and compare the plist files between my working test MacBook Air and my screwed up MacBook Pro…

    September 17, 2013 at 2:04 PM #6662



    Don’t blame you for not wanting to let it go. I personally refuse to be beaten by a mere computer.

    Suggestion. Have you tried creating another user account on the same laptop and seeing if it will sync to iCloud? While it is possible it is the OS, I have seen bad settings in a user’s account do some pretty weird things.

    Also, take a look at PlainCloud. It’s a handy little app for showing you all of what is in your iCloud account. Yes, you can always cd in ~/Library, but I find it handy nonetheless.

    September 17, 2013 at 2:49 PM #6663


    ArsAstronautica, excellent idea to further narrow down the problem!

    I did just that (and the obvious steps like activating iCloud, Tap Forms, and so on).
    No luck: the Mobile Documents folder for the new user remains desperately isolated from the cloud.

    So, something is wrong with my MacBook Pro configuration, not the user configuration.

    Since my working test MacBook Air is also on Mac 10.7.5, I did something crude:
    I copied and replaced the following from the MacBook Air to my main machine (the MacBook Pro):
    – /System/Library/LaunchAgents/com.apple.ubd.plist
    (the daemon launch file)
    – /System/Library/PrivateFrameworks/Ubiquity.framework
    (the actual framework, I think)
    I have checked the ownership and permissions (the framework for example seems to require root:wheel, this was already correct before anyway)

    Guess what…no change (after the ceremonial reboots, that are now a bliss with my new SSD ;-) ).

    Since I am trying stupid and crude things, are there other parts of this annoying ubd deamon that I could crudely copy from my working MacBook Air to my troublesome MacBook Pro, just in case?

    PS: PlainCloud seems to require Mountain Lion anyway.

    September 17, 2013 at 2:56 PM #6664



    While it says that PlainCloud only works with ML, it will work with Lion. I have it on my Lion Mac Pro Desktop.

    As to the rest, have you considered calling in an exorcist? :-)

    About the only thing left would be a fresh OS install, a new user account and forgo the restore from backup. If that works, then perhaps a selective restore of data and key applications.

    September 17, 2013 at 3:02 PM #6665


    By the time I find a Unix-based exorcist, Mavericks should probably be out ;-)
    So I’d rather keep my hopes up with your initial OS upgrade suggestion!

    If Mavericks doesn’t help, then yes, at some point, I’ll be desperate enough to do a real clean install…

    Thanks again!

    October 1, 2013 at 8:18 PM #6815


    OK, this is weird. After updating to 10.8.5, my laptop, which formerly NEVER had any issues with iCloud document synching now stubbornly refuses to do so. It’s not a Tap Forms issue. It simply does not sync any files in iCloud, be they TF, iWork or whatever.

    My other Macs still work fine. My iPhone and iPad are working fine. My laptop just stopped dead. Oddly, Mail, Notes, Safari, Contacts all work fine. Documents, Find my Mac, Back to my Mac, and iMessages just stopped working.

    On the positive side, I do have a ticket in with Apple on this, so I expect we’ll get it sorted out. From the discussions I gather that some folks have had this issue and Apple is working on tracking it down. If I hear anything, I’ll pass it along.

    October 25, 2013 at 4:14 AM #7021


    Hi, just to confirm that updating to Mavericks solved the issue. iCloud docs (=Tap Forms) is now syncing perfectly.
    (On the other hand, FaceTime and iMessage won’t let me sign in, but that’s another story ;) )


    October 25, 2013 at 10:09 AM #7022


    That’s great to hear Pierre!

    October 25, 2013 at 10:11 AM #7023



    You said ” Oddly, Mail, Notes, Safari, Contacts all work fine.”.

    That’s not actually odd since those use completely different iCloud sync services that are in no way related to Documents & Data syncing. They have completely different back-end services.

    iCloud Sync is actually comprised of about 20 different services as you can see here on Apple’s System Status page:




    October 27, 2013 at 1:43 PM #7067


    Hi again, this is my last post Brendan ;-)

    I am posting this for you only: I *may* have found the solution to my iCloud syncing problem under Lion. Hopefully this *might* be useful for some other Tap Form users still under Lion. Remember I am just a geek, you are the developer and know a lot more than me.

    – I had no iCloud documents sync under Lion (thus, no Tap Forms sync)
    – I upgraded to Mavericks, document sync started to work
    – However, even after trying dozens of fixes, FaceTime and iMessage wouldn’t log me in

    The last point is important. After extensive browsing, I learned that in some OS X versions, and in some Apple applications, the computer serial nr is used as an authentication method.
    Problem was: I had my motherboard replaced by an Apple Care centre after it had failed, 2 years ago. Since then, my serial nr didn’t appear anymore in “about my mac” (“Serial number: #”)
    I also learned that I am not alone: although Apple tech guys are supposed to “reset” the serial number of the new logic board after exchanging it, many don’t do it.

    So to make things short, some people solved their Facetime/iMessage issues by going back to Apple, and asking them to properly set the mac serial number again (takes 2 minutes for them with the right special bootloader…).
    This is what I did, and guess what: iMessage and FaceTime now work perfectly.

    The link with Tap Forms syncing under Lion?
    Well, it may be far fetched, but here is a educated guess: maybe under 10.7, iCloud documents sync relied on the Mac Serial Nr (just as iMessage and FaceTime rely on it under 10.9).
    Without this serial number set, there was no way I could have gotten iCloud document sync to work under Lion.

    Sadly, since my Lion is gone, I cannot confirm this 100%. But I have a strong belief I found the culprit: a lazy Apple tech guy that didn’t want to loose 2 minutes re-flashing my Mac serial number after a logic board replacement.

    I love my syncing Tap Forms by the way ;)


    October 27, 2013 at 2:01 PM #7069



    As I mentioned earlier, I was having no issues syncing with ML until the last update and it stopped syncing. Other machines were fine, just my laptop would not sync. I updated to Mavericks and now I can sync with iCloud. However, like Pierre, I am now locked out of Messages and FaceTime, both of which worked under ML.

    It would seem I have the same issue as Pierre, a motherboard replaced by Apple without the serial number burned in. The Apple boards note that this can be an issue. So off to the Apple Store I go.

    October 27, 2013 at 11:32 PM #7093


    Wow, that’s very very interesting. It’ll give me one more thing to ask a customer if they just can’t get iCloud sync to work. I remember trying very hard with a guy over Skype who lived in Hawaii and we just couldn’t get his iCloud sync to work no matter what. I tried all the tricks. But I never thought to ask him about the serial number.

    Thanks for all the sleuthing you guys have been doing!


Viewing 28 reply threads

You must be logged in to reply to this topic.